To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

admin frontend not available

nemo W/ Alumni Posts: 7 Security Scout

This is about F-secure Internet Gatekeeper for linux 4.07. It's seemingly failing shortly after installation.


I installed fsigk_4.07.3280_all.deb on a Debian 6.0.4. Everything went without an error.

I see a process at port 9012:


tcp        0      0  *               LISTEN      271/java


root       271  0.0  2.9 185928 30504 ?        Sl   17:38   0:01 /opt/f-secure/fsigk/java/bin/java -client -Xmx64m -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=/opt/f-secure/fsigk/tomcat/conf/ -Djava.endorsed.dirs=/opt/f-secure/fsigk/tomcat/endorsed -classpath /opt/f-secure/fsigk/tomcat/bin/bootstrap.jar -Dcatalina.base=/opt/f-secure/fsigk/tomcat -Dcatalina.home=/opt/f-secure/fsigk/tomcat org.apache.catalina.startup.Bootstrap start


But when I point a browser (tried IE8, Firefox 11, Chrome, wget) nothing happens. strace shows a stalling:

futex(0xb6d64bd8, FUTEX_WAIT, 273, NULL


After a while, the connection will timeout. Nothing in the logs.


I removed ipv6, there is no other Java but the provided one. I'm out of clues. Anyone able to help?


 (edit: added product details.)


  • Peter
    Peter W/ Alumni Posts: 127 Threat Terminator




    If this is a 64-bit platform, check if ia32-libs and lib32nss-mdns packages are installed. If they are, suggest opening a support ticket so we can have a closer look at the configuration.


    Please include the fsdiag package with the ticket. To create the fsdiag in IGK Linux, use:


    # cd /opt/f-secure/fsigk ; make diag


    To create the support ticket, use this page.


  • nemo
    nemo W/ Alumni Posts: 7 Security Scout

    Alright, so I tried everything on a 64-bit-machine including the mentioned libs. I got a little bit farther (once), the browser seemed to redirect to login.jsf, but then it stalled like before. I'll open the support ticket. Thank you so far and best regards.

  • nemo
    nemo W/ Alumni Posts: 7 Security Scout

    Found it. On a vm (openvz or kvm or vmware doesn't seem to make a difference) with many Kernels, a lot of Java/Tomcat stuff seems to fail, when there is only one cpu assigned. Assigned a second cpu and everything is fine. Beats me, but works.

  • keiooz
    keiooz MyAccount Posts: 9 Security Scout

    If you are working with your VM's, this stuff usually occured as you thought something is wrong. Good to know that you have it all fixed. image

This discussion has been closed.