To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

F-Secure Linux Security installation problems

labka W/ Alumni Posts: 2 Security Scout

I tried installing F-Secure Linux Security on my Linux machine. We have a FSPM running on a Linux server and I was able to install and use FSPMC (Linux client) on my system.


But installing FSAV from fsls-11.10.68-rtm.tar.gz is rather problematic. All the following things were done as root. Server addresses and keycodes were changed for this post.



# ./fsls-11.10.68 
F-Secure Linux Security installation
Copyright (c) 1999-2015 F-Secure Corporation. All Rights Reserved.


/opt/f-secure/fsav/sbin/ 334: /opt/f-secure/fsav/sbin/ /opt/f-secure/fsav/libexec/license-check: not found
/opt/f-secure/fsav/sbin/ 334: /opt/f-secure/fsav/sbin/ /opt/f-secure/fsav/libexec/license-check: not found
Please enter the keycode you have received with your
purchase of F-Secure Linux Security.
Validating keycode...

/opt/f-secure/fsav/sbin/ 334: /opt/f-secure/fsav/sbin/ /opt/f-secure/fsav/libexec/license-check: not found
Unknown error (code 127).
Please enter the keycode you have received with your
purchase of F-Secure Linux Security.
No keycode entered.
You can later upgrade the product to fully licensed by running
/opt/f-secure/fsav/sbin/ 1: /opt/f-secure/fsav/sbin/ /opt/f-secure/fsav/libexec/license-check: not found
/opt/f-secure/fsav/sbin/ 77: /opt/f-secure/fsav/sbin/ /opt/f-secure/fsav/libexec/license-check: not found
# ls -l /opt/f-secure/fsav/sbin/ /opt/f-secure/fsav/libexec/license-check
-rwxrwxr-x 1 root root 67356 22. Nov 2016  /opt/f-secure/fsav/libexec/license-check
-rwx------ 1 root root 10895  3. Dez 19:05 /opt/f-secure/fsav/sbin/


I kept on trying to complete the installtion and provide the key at another time:



# ./fsav-config
Select language to use in Web User Interface
	[1] English (default)
	[2] Japanese 
	[3] German 
	[4] French 

Please select 1, 2, 3, or 4 [1]:  

We will now ask you some questions regarding the installation of this product.
A default value will be shown in square brackets after the question. To accept
the default, just press enter.

Do you want to configure the product to run as standalone, Policy Manager managed
or PSB managed?
Select [s]tandalone, Policy [M]anager managed, or [P]SB managed [standalone]: M
Address of F-Secure Policy Manager Server [http://localhost/]:
Give the file location [/root/]: 
No such file /root/

I tried locating on my system and on the server running FSPM but couldn't find it. The webinterface of the client is not reachable.


I'd like to get this installation running as I'm planning to install it on many more Linux machines in our network in the future.



  • labka
    labka W/ Alumni Posts: 2 Security Scout

    I've gotten a bit further. I copied the from a Windows PC into my /root directory and was able to "complete" the installation with a bunch of errors. It still didn't take the key I provided, but I was able to start the software. But when I try to open http://localhost:28080/fsecure/webui/ I get a Tomcat error page. The same has happened on a different system running the current stable Debian release.


    HTTP Status 500 - java.lang.NullPointerException
    type Exception report
    message java.lang.NullPointerException
    description The server encountered an internal error that prevented it from fulfilling this request.
    javax.servlet.ServletException: java.lang.NullPointerException
    root cause
    note The full stack trace of the root cause is available in the Apache Tomcat/7.0.55 logs.
    Apache Tomcat/7.0.55

    This is the furthest I got installing fsls-11.10.68-rtm.tar.gz on a few different distributions. It always ends with the Tomcat NullPointerException.

  • MJ-perComp
    MJ-perComp W/ Alumni Posts: 669 Firewall Master

    The easiest way to obtain the is to use a webbrowser and oper the welcomepage of your PMS.


    Read the text. the word "here" offers you to download the file ADMIN.PUB. that is the file youz are looking for.


    For the correct keycode ask your partner if the keycode matches for the version you try to install.


    Finally read the realease notes carefully, if your distribution is supported.
    Esp. if you have a 64bit Version you might need to add some 32bit libraries before starting.



This discussion has been closed.