To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Freedome for Business doesn't activate on Android 9.0

oqstone W/ Alumni Posts: 1 Security Scout

Tried to install the Freedome for Business on Android 9.0 device (Nokia 7.1 with Android One). I used PSB Portal to send an email containing the installation link. Device Agent seemed to install correctly and asked all the permissions. The device was shown on Portal as Managed but the Freedome for Business was not pushed to the device. I also checked for a notification about the download but I didn't see any. I tried reinstalling the Agent several times and I also tried downloading Freedome for Business from Play Store. I was able to download Freedome from Play but it didn't activate. Is Android 9.0 supported?


Update: This should have been posted under the PSB category. The problem told above might be the service that has been down since 27 December as told in a recent post on Known issues category. Why didn't we get any notification about the died service? I spent couple of hours yesterday trying to figure out what I was doing wrong. Also checked this forum with no help. Hope the problem will be fixed soon!