To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

F-Secure interfering with visual studio code

Options
Willy7593
Willy7593 W/ Alumni Posts: 3 Security Scout

I have tried to compile and run a simple 50 line program in visual studio code.

 

However, it took me over 3 minutes to compile and run. 

 

Once I have unloaded F-secure, my code compiles and runs instantly.

 

Can someone please help me with this issue? I cannot unload F-secure all the time while I am coding, then I will lose the point of using F-secure.

 

Comments

  • Ukko
    Ukko W/ Alumni Posts: 39 Cybercrime Crusader
    Options

    Hello,

     

    I am only an F-Secure user (their home solutions).

     

    Perhaps, you could try to reach out their official Support Channel (for example, web-chat):

    Support Agents with an ability to troubleshoot further and to analyze situation much more better.

     

    But as a workaround - you can try to use "Exclusion list" (not recommended).

    For example, to add compilation folder to list of exclusions or Visual Studio folder itself. Need to verify what can be helpful there.

    In general, you could also try to disable certain feature (for example, real-time scanning OR ransomware protection, DeepGuard to surely understand what is the main reason).

     

    Thanks! 

  • MonikaL
    MonikaL W/ Alumni Posts: 206 W/ Former Staff
    Options

    Hi,

     

    Could you please provide details of the F-Secure product you are using.

     

    Regards,

    Monika

  • Willy7593
    Willy7593 W/ Alumni Posts: 3 Security Scout
    Options

    Dear MonikaL, 

     

    I am using F-Secure client security premium.

    Please let me know, what other information can I provide for you?

    image.png

     

  • Willy7593
    Willy7593 W/ Alumni Posts: 3 Security Scout
    Options
    Thank you Ukko!
    I've asked on the official support channel and is waiting for their reply.
    Tried your exclusion list as well, not working as good as unloading though. There might be another solution! Thanks
  • ms113
    ms113 W/ Alumni Posts: 1 Security Scout
    Options

    Have you recieved a solution, I have the same problem and would appreciate any advice?

This discussion has been closed.