To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Java Pages dont work unless FW disabled

JPD
JPD W/ Alumni Posts: 5 Security Scout

Some time over the past few weeks an F-Secure update has stopped the ability of Java applets from running.  These are legitimate consoles used for managing storage or simply for Java testing. I cant find anything in Google on this but its deffinately not browser related...

 

Anyone got any ideas, its annoying have to 'allow all traffic' for something that should already be allowed...

 

Thanks

JP

Comments

  • Jari-P
    Jari-P W/ Alumni Posts: 35 Cyber Knight

    Hi JPD,

     

    Latest Java version is using IPv6 traffic. Please allow IPv6 from the F-Secure client.

     

    F-Secure -> Settings -> Network connections -> Settings -> Select IPv6 traffic filtering options : normal

  • JPD
    JPD W/ Alumni Posts: 5 Security Scout

    Hi Jari-P

     

    Thanks for your reply, this is already set to Normal.

     

    JP

  • Jari-P
    Jari-P W/ Alumni Posts: 35 Cyber Knight

    Hi JPD,

     

    Try reinstalling Java and F-Secure application one more time. If the problem persist please contact our technical support.

     

    http://www.f-secure.com/en/web/business_global/support/contact/request

     

    Please provide fsdiag file also in the ticket

     

    http://www.f-secure.com/en/web/home_global/support/contact/fsdiag

     

     

     

  • jackma
    jackma W/ Alumni Posts: 25 Cyber Knight

    Hi,

     

    please make sure the "remote host" value of your firewall rule looks like this:

    0.0.0.0/0,::0

     

    and not like this:

    0.0.0.0/0 (missing the ipv6 parameter).

     

    "0.0.0.0/0" (ipv4) and "::0" (ipv6) basically means "anything / any host".

  • JMu
    JMu W/ Alumni Posts: 1 Security Scout

    There is a typo in there? The correct string is  0.0.0.0/0,::/0

     

    Also I changed from the PM Advanced Mode: Firewall Engine / IPV6 Filtering Mode = Normal.

     

    Cannot believe this is for a network banking software which uses Java.... :)

  • JPD
    JPD W/ Alumni Posts: 5 Security Scout

    All

     

    Might be worth pionting out that this issue doesnt affect everyone and as for adding IPv6 info, well IPv6 is disabled on the local machines and the Mgt Console is v9.0 so doesnt have the option to omit IPv6...

     

    Sorry for the delay in responding, i appreciate everyones efforts though...

  • KG-Admin
    KG-Admin W/ Alumni Posts: 6 Security Scout

    Had the same issue, but after changing IPv6=Normal scanning (under the advanced view-firewall settings) and ensuring that the firewall rules were correctly setup for IPv6, my java issues seem to have disappeared. At least on the test clients.

     

    Testing amongst users and awaiting feedback from them, but it looks promising at least

  • KG-Admin
    KG-Admin W/ Alumni Posts: 6 Security Scout

    Ok, feedback confirms this as the solution (in my case at least). There were some inconsistencies with some users not been able to use Java, but in ALL those cases it was shown that multiple Java versions were present.

     

    By removing all versions except for the latest (7u7) and having the correct rule in the PM, Java works as its supposed to. Hope this helps

This discussion has been closed.