To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

F-Secure server security blocking backup activity

Jith W/ Alumni Posts: 2 Security Scout

Hi All,


I am facing a strange issue with F-Secure server security 9.20. After installing F-Secure on one of the server, the daily backup job fail to run. I tried disabling Deepguard (which is the only additional feature available in Server security) but did not help. Even tried with stopping all the f-secure related service on the server with no luck.

The funny part is after all when I do a complete un-installation of server security the Backup job works fine!


The backup software we use is : HP DataProtector 6.0


Please suggest.


  • Vad
    Vad W/ Alumni Posts: 1,069 Cybercrime Crusader

    Hello Jith,


    It sounds really strange for me that stopping F-Secure services doesn't help. Could you, please, check DeepGuard "Monitored Progarms" list in WebUI. Is your backup program present in it? What Windows Server version you have?


    I would recommend you to collect fsdiag from affected server and contact our support.

    You can also try SS 10.00 Beta, or wait for SS 10.00 RC, which will come in a short time. Version 10 has newer improved version of DeepGuard.


    Best regards,


  • Dmitriy
    Dmitriy W/ Alumni Posts: 179 Threat Terminator

    Hello Jith,


    Have you tried to add HP DataProtector 6.0 to process exclusion list? Unfortunately, I don't know which process(es) should be excluded, but you will probably find them in the task or service list, or ask from HP support. When a process is added to exclusion list, all files that this process reads/writes will be omitted on scanning.


    Hope this helps,



  • Jith
    Jith W/ Alumni Posts: 2 Security Scout


    Hi Vad,


    True... Even now when i think about it, I find it very strange indeed. Smiley Frustrated


    I did check the Deepguard monitored programs and the applications related to HP backup were available and that they were set to "allow" by Deepgurad.


    It’s quite hard to convince the customer for installing a beta version on a production server when it’s running without any backup, wouldn’t you agree?


    Hi Dimitriy,


    I excluded the files and process related to the HP Data protector, which did not help.

    I am not in a position to seek the support from HP because all the other servers are being backed up without any errors even with F-Secure server security installed.


    Anyway I am working with support team for the same. Unfortunately the first support diag log didn’t have much information about failure reason; hence we enabled a complete debugging and waiting for the development team to provide further input after investigating the debug logs.


    The one probable cause we are guessing that the problematic server is infected with virus (sality), and when the backup agent is trying to access any of these infected files, F-secure is restricting the access and as a result it keeps failing. Can’t get into a conclusion until Development team come back with their inputs.


    Hope for the best Smiley Happy





  • Chrissy
    Chrissy W/ Alumni Posts: 40 Digital Defender

    Hi Jith!


    Just checking in to see if you are still having an issue, or if things have been corrected.  Let us know if you found a solution, or if you need more advice from us!


    Chrissy T

    F-Secure Community Manager

This discussion has been closed.