To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Java not starting until GateKeeper service is stopped

AndersF W/ Alumni Posts: 1 Security Scout



Im using the F-Secure PSB Workstation Security 10.10 build 177 on my Windows computer.


When accessing certain work applications, using Java in a web browser, sometimes the Java application wont start (or waits for a very long time).
I have found out that if I stops the Windows service called FSGKHS the java application starts immediately.


The same goes for the "Launch profile editor" button in F-secures online admin pages. Sometimes it also hangs until Ive stopped the FSGKHS service.


Whats confusing, and makes it hard for me to reproduce this problem every time, is that if I start the FSGKHS service and then accessing the same Java application it works! No hanging of the Java occurs.


And then, after a not known time period, the same Java application wont start again. It could be minutes, it could be hours. Its hard for me to tell.


Ive activated the Java-console on my computer so I actually sees when the "hanging" is released by stopping the FSGKHS service. Because immediately after the stopping the Java-console appears.


So I can see that FSGKHS is doing something during the java-loading-process.


How can i get rid of this problem without having to lower my security by disabling the FSGKHS service?


I have tried to create a custom profile for my computer which is excluding (excluded objects) the Java deployment cache folder on my computer, but im not sure if that is the right solution.


This problem occurs on both Windows 7 and 8 computers.


Any help is appreciated,




  • Vad
    Vad W/ Alumni Posts: 1,069 Cybercrime Crusader

    Hello Anders,


    We do not have any similar reports from other customers, so we need more details for investigation - Support tool report (fsdiag), and, probably, Gatekeeper and Scanner Manager debug logs .

    Please, contact support.


    Best regards,


  • etomcat
    etomcat W/ Alumni Posts: 1,172 Firewall Master

    Dear Vad,


    We have a recent report where JRE would not run in the browser (IE or other) with FSCS 11.5x in place. Upgrading to FSCS 11.60 / FSPM 11.21 solved the problem.


    I wonder if FSAV PSB 10.10 corrsponds to FSCS 11.00 or even earlier, with regards to the tech incorporated under the hood?


    Thanks in advance, Yours Sincerely: Tamas Feher, Hungary.

This discussion has been closed.