To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Update 1709 fails to install F-Secure

0nlinq_supp0rt W/ Alumni Posts: 17 Security Scout



I have a problem with installing the Fall Creators Update 1709 from Windows.

At the moment i have 5 PC's that have this problem. 

i noticed that all of these PC have F-Secure Business Computer Protection.


Is this problem known that this update cannot be installed because F-Secure is installed.


Hope to hear from you.


Kind Regards,

Stefan Baan


  • 0nlinq_supp0rt
    0nlinq_supp0rt W/ Alumni Posts: 17 Security Scout

    Hello Vad,


    Thank for your reply.

    The update was launched at november 2017. If F-Secure was the cause of this problem than someone already post it on your community site. So i don't think that the case.


    Thank for your answer.


    Best Regards,

    Stefan Baan

  • MJ-perComp
    MJ-perComp W/ Alumni Posts: 669 Firewall Master

    Have you tried to install without F-Secure (use UI-Tool!) It's worth a try. But I fear the problem is somewhere else. I even tried to install from a DVD and failed. So i ended up with a complete reinstall of W10.
    A hint I found browsing through various google pages: switch your system to UEFI, do not use BIOS.

    If that did the trick I will only see when the next, 180x arrives.

This discussion has been closed.