To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

F-Secure Device Agent, Freedome for Business not communicating on Sony Xperia XA2 Ultra



I installed F-Secure Device Agent via PSB EMEA portal, the version installed is 4.9.3 (r25813). The device shows up in PSB portal with Managed status and ember indicator. There was one pending operation, telling me "Waiting for the device to connect." Trying to send device status update doesn't help, as there is now two pending tasks instead.


I am using Sony Xperia XA2 Ultra H3213, which is running Android 8.0.0, firmware version 50.1.A.13.83. The installed Android is not rooted, but it has unlocked bootloader, because I tested Sailfish OS on the device, successfully, then flashed back to Android using Sony Emma Flash Tool.


I think this boils down to three questions: Does unlocked bootloader affect this? Does Sony Emma flashed official Android image affect this? Does the fix for Device Agent work on Sony Xperia XA2?


Thank you!


Matti Viljanen


  • JonLin
    JonLin W/ Alumni Posts: 2 Security Scout

    I have the same problem 4.1.2018. Honor 8 with default Android.

  • MattiViljanen
    MattiViljanen W/ Alumni Posts: 2 Security Scout

    Thanks, I followed that link and there was more issues with PSB1 portal. The comment was ovelined at some point, so I tried the installation again, and now it works.

This discussion has been closed.