To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Software updater - version of software is not recognized

Options
BobJones
BobJones W/ Member Posts: 3 Security Scout
edited February 12 in Elements Endpoint Protection

Hello,

I've tried to update putty to version 0.78 using software updater. Unfortunately update was always failing. I did the update manualy more than a week ago.

The issue is, that the entry still exists in software updater for this device, but it should not be there anymore since putty was updated.

Do you know how can I remove this entry?

Comments

  • Sethu Laks
    Sethu Laks W/ Partner, W/ Staff, W/ Moderator Posts: 243 Moderator
    Options

    Hi @BobJones

    May I know the version of Elements Agent running on your machine?

    Could you also please try uninstalling, reboot and re-install the latest version of Elements Agent and check scan for software update from the EPP Portal again?

  • BobJones
    BobJones W/ Member Posts: 3 Security Scout
    Options

    Hi @Sethu Laks

    Version 23.3

    Reason of failed insallation below:

    I will try to reinstall Elements Agent.

    Thanks

  • JamesC
    JamesC W/ Partner, W/ Staff, W/ Moderator Posts: 519 Moderator
    Options

    Hi @BobJones - apologies to hear that you are going through issues with updating Putty. I had to check with our product developer and below is the official statement from our Software Updater vendor:

    Since version 0.78, the older Putty version needs to be uninstalled first. This is according release note: PuTTY Change Log (https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html)
     
    "Note: installing the 0.78 or later Windows installer will not automatically uninstall 0.77 or earlier, due to a change we've made to work around a bug. We recommend uninstalling the old version first, if possible. If both end up installed, uninstalling both and then re-installing the new version will fix things up."
     
    Therefore, in order to implement the new flow for the Putty, please uninstall the current version and then retry installing v0.78 again, via our patch data.

  • BobJones
    BobJones W/ Member Posts: 3 Security Scout
    Options

    Hello @JamesC

    I found and removed old version 0.70

    Missing software update entry disappeared

    Thank you for your help!

This discussion has been closed.