To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Cannot update F-Secure Linux Security

garb
garb W/ Member Posts: 7 Security Scout
edited February 12 in WithSecure Business Suite

Hi, I have a problem with updates.

I downloaded fsdbupdate9.run, then ran "dbupdate fsdbupdate9.run".

I tried with absolute path too, nothing works, I get this output :

"Verifying archive integrity... 100%  MD5 checksums are OK. All good.

Uncompressing F-Secure Database Update 100% 

Sorry, cannot determine final data directory location. Update failed.

You might want to set FSAUA_DATADIR environmental variable to point to

F-Secure Automatic Update Agent data directory.

E.g. FSAUA_DATADIR="/var/opt/f-secure/fsaua/data" fsupdate3.run

15:04:19 /opt/fsecure/fsdbupdate9.run returned 1

dbupdate: /opt/fsecure/fsdbupdate9.run failed! (1)"

I tried to set FSAUA_DATADIR manually like suggested, with different paths.

Everything runs as root user so it cannot be related to permissions.
I dont' know what to do anymore.

Answers

  • LiselotteP
    LiselotteP W/ Staff, W/ Community Manager Posts: 203 Community Manager

    Hi @garb !

    I sincerely apologize for the inconvenience, your question has been retrieved from the spam queue and we'll provide you with a response in the next 12 hours.

  • JamesC
    JamesC W/ Partner, W/ Staff, W/ Moderator Posts: 487 Moderator

    Hi @garb , we have discussed with your account manager. You need to be using Linux Security 64, as Linux Security 11 is now end-of-life (EOL)

    It appears your distributor made a mistake of giving the license of LS11.

    We suggest to contact your distributor again to get a new license certificate for LS64.

This discussion has been closed.