To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Client security 16.00 says "your subscription has expired or it have been removed...

Options
Toma
Toma W/ Member Posts: 6 Security Scout

I Maintain a closed system with no internet access.

After I upgraded the PolicyManager and all the clients to WithSecure 16.00 all was fine for about a month but now all clients states that "your subscription has expired or it have been removed. Please contact your administrator to renew the subscription"

Licenses are all okay on the policy manager and it is configured as a closed system. Any idea what might be causing this?

Answers

  • JamesC
    JamesC W/ Partner, W/ Staff, W/ Moderator Posts: 521 Moderator
    Options

    Hi @Toma ,

    This is a new feature in Server Security and Client Security 16,  it shows that message, if Policy Manager is not able to register itself to our backend or customer number (license) has expired.

    It might be that Policy Manager Server is not able to connect to the new registration server. First Make sure that it has access to these addresses:

    • guts2.fsapi.com
    • guts2-old.fsapi.com
    • corp-reg.fsapi.com
    • api.doorman.fsapi.com
    • baseguard.doorman.fsapi.com
    • a.karma.sc2.fsapi.com
    • restmc.mind.sc2.fsapi.com


    If license is expired you need renew it. If all these are done and Client Server is still showing that expired message, wait a while, and if it is changing to normal, then we suggest to submit WSDiag logs from PM and client here - https://www.withsecure.com/en/support/contact-support/email-support

  • Toma
    Toma W/ Member Posts: 6 Security Scout
    edited April 11
    Options

    Hi @JamesC

    Like I stated in my post this is a totally off-grid system, no connection to the internet is allowed not even through a proxy.
    Is there a way to tell the clients the license without an internet connection?

    The policy manager is in off-line mode and i did get an off-line registration file which is added according to these guidlines

    Policy Manager 16.x and later:
    Copy the offline registration file to the folder: C:\ProgramData\WithSecure\NS\Policy Manager\Policy Manager Server\data

    Restart the WithSecure Policy Manager Server service by typing the following commands in an elevated command prompt (CMD)

    net stop wspms
    net start wspms

  • Toma
    Toma W/ Member Posts: 6 Security Scout
    Options

    An update to this issue.

    When i uninstalled the client through policy manager and installed it again on my own computer it is no longer complaining. But I would not rather not do that for all the existing clients.
    And if there is some kind of "trial"period the issue would probably come back after that

  • Toma
    Toma W/ Member Posts: 6 Security Scout
    Options

    Update #2
    Now for some odd reason all the clients managed to update new definitions and the subscription expired message disappeared. I was on a holiday for 2 weeks and there was no definition updates during this period. Could this have been the issue?
    Well anyway, everything seems to be in order now. Not quite sure what fixed it but glad it is fixed.