To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Installing Computer Protection to Mac (Catalina)

AnttiKU
AnttiKU W/ Alumni Posts: 1 Security Scout

Hi! Client has Mac computers. Installing went fine but one computer won't prompt the Accept button on System Preferences -> Security and privacy -> General tab. After installing Computer protection won't work properly. Any ideas?

Answers

  • JamesC
    JamesC W/ Partner, W/ Staff, W/ Moderator Posts: 504 Moderator

    Hi AnttiKu

    Please try the below suggested Solutions

    After installation of the Mac product on macOS High Sierra or higher, a red F-Secure (X) icon may appear when running real-time scanning.


    This is due to a new security feature, which has been introduced in macOS High Sierra (10.13) or higher.

    During first time installation, the security feature requires you to allow system software from F-Secure.

    Until the software is allowed, real-time scanning will fail.

    Once the installation is complete, allow F-Secure software as follows:

    1. Go to System Preferences > Security & Privacy, and select the General tab.
    2. Click Allow. Once this is done, the icon status changes to normal and the error message disappears.

    Note: The steps described must be performed locally on the machine and not remotely.


    Full instructions with pictures: https://community.f-secure.com/t5/Business/Issue-with-real-time-scanning/ta-p/100546


    In case the mentioned solution above does not work, carry out the following solutions one by one and verify if the real-time scanning could be enabled.


    Solution 1:

    1. Check in System Preferences > Security & Privacy > Privacy > Accessibility and remove or disable 3rd party accessibility software such as the Better Touch Tool or MagicPrefs.
    2. Go to System Preferences > Security & Privacy.
    3. Select the General tab.
    4. Click the Allow button.

    Solution 2:

    1. Check in System Preferences > Keyboard > Shortcuts > Full keyboard access to enable full keyboard access.
    2. Go to System Preferences > Security & Privacy, and select the General tab.
    3. Use Tab key to move the focus on the Allow button
    4. Press Spacebar on your keyboard while the Allow button is active.


    Solution 3:

    Add F-Secure Team ID (6KALSAFZJC) to the list of approved kext developers by using "spctl kext-consent add 6KALSAFZJC" command in the Recovery mode.

    Refer to the following page for more detail information: 

    https://developer.apple.com/library/content/technotes/tn2459/_index.html#//apple_ref/doc/uid/DTS40017658-CH1-TNTAG4

This discussion has been closed.