Issue with Install

Hi I have an issue with installing F-Secure Client Security Premium 15.30

We are logged in with Admin and UAC is disabled

' There is a problem with this windows installer package. A Program run as part of the setup did not finish as expected. Contact your support personanel or package vendor.'

15.30 work fine on windows 10

The previous version installed on both windows 10 and 11 fine.

Can someone please advise

Answers

  • Sethu Laks
    Sethu Laks Posts: 125 Moderator

    Hi @secure00023

    Thank you for reaching out to WithSecure Community!

    Its hard to say without checking the fsdiag logs, howerver, I doubt its most likely there are some traces of an old/broken WithSecure product installation on the computer, which then cause issues with a new installation.

    Follow these steps to check if the Windows installer service is running correctly:

    1. In your keyboard, press Windows key + R
    2. Type services.msc and press Enter
    3. In the Services window, locate Windows Installer and check if the services are running
    4. Right-click Windows Installer and select Properties
    5. Set the Startup type to Automatic
    6. Click OK
    7. Proceed to install the F-Secure software again.

    If the issue remains after verifying that Windows Installer service is set to Automatic, it's possible that the previously failed installation has left broken traces and it's preventing the new installation to take place. To solve that, run the WithSecure uninstallation tools to remove the previous installation traces.

    Note: Kindly take NOTE that the WithSecure Uninstallation Tool (UninstallationTool.exe) uninstalls all WithSecure products installed on your computer.

    1. Log on to the computer with administrator rights
    2. Downad the Uninstallation tool and run it.
    3. With WsUninstallationTool.exe, you can select which product or components you want to remove
    4. Click Restart when prompted to remove remaining files

    The uninstallation is complete when the computer has restarted. After the restart, you can retry the installation of the WithSecure product.

    Please do not hesitate to contact us if you have any further questions!