To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Debian 12 support for WithSecure Elements Agent

arose
arose W/ Member Posts: 1 Security Scout

Hi,

I set up a new server with Debian 12 and when trying to install the WithSecure Elements Agent it said operating system version debian 12 not supported

Is there an ETA for Debian 12 support for WithSecure Elements?

Best Answer

  • JamesC
    JamesC W/ Partner, W/ Staff, W/ Moderator Posts: 487 Moderator
    Answer ✓

    Hi @arose ,

    Thank you for contacting WithSecure

    With regards to your inquire, at the moment we do not have and ETA but we are aiming to support Debian 12 by the end of Q3 2023.

Answers

  • mpegard
    mpegard W/ Member Posts: 1 Security Scout

    Hi, there,

    Do you have any news about Debian 12 support?

    It will soon be 4 months since the OS was released and this is blocking the release of new servers on this distribution 😕.

    Thank you in advance for your reply.

    Best regards

  • Jsubei
    Jsubei W/ Member Posts: 1 Security Scout

    Same concern here, we are on Q4 now and no news for the debian 12 support …

    All the best

  • eTienne
    eTienne W/ Member Posts: 1 Security Scout

    Well, I must add a +1 …

    Wish to have it before Halloween :D

    Regards, everyone !

  • JamesC
    JamesC W/ Partner, W/ Staff, W/ Moderator Posts: 487 Moderator

    Hi @eTienne @Jsubei @mpegard @arose


    Apologies for the delay in supporting Debian 12.

    We are still following up with R&D.

    If you wish to install Linux Security 64 on an unsupported Debian 12, you may use an additional command --override-distro=debian:11

    For example:
    bash f-secure-linuxsecurity/f-secure-linuxsecurity-installer --override-distro=debian:11

    Note - However, we cannot guarantee its functionality. Though product may work right after installation, the next channel release might break certain parts and will not be able to support an unsupported scenario.