To stay updated on your favorite discussions, please create an account or log in. Then, click the Bookmark icon to subscribe and receive notifications.

Browsing extension not enabled in Edge

Wei
Wei W/ Alumni Posts: 2 Security Scout

Installation is successful by using the GPO, but the browsing extension is disabled (and greyed) in the browser.

Tried other extensions with no problem, only the F-secure browsing extension is impacted.

The extension is working fine on Chrome and Firefox.

Followed this tutorial: https://help.f-secure.com/product.html#business/psb-portal/latest/en/task_D93378D44C88451E81CE6B3A8C7A5F55-psb-portal-latest-en

Did I miss something for the Edge browser?

Best Answers

  • MonikaL
    MonikaL W/ Alumni Posts: 206 W/ Former Staff
    edited April 2022 Answer ✓

    Hi,

    Browsing Protection works in Microsoft Edge with the latest updates in place.

    If the Microsoft Edge web browser does not prompt the end-user to enable the Browsing Protection extension when it is opened for the first time, you can enable it in Edge’s extensions menu.


    If you need to forcefully enable the Browsing Protection extension in Microsoft Edge via GPO by doing the following:

    1. Download the administrative template for Edge Chromium here

    NOTE: Select the respective build and platform, and click on "Get policy files" to download the administrative template

    1. Extract and import the administrative template(from \windows\adm\msedge.adm) you downloaded in step 1 into Group Policy Editor.
    2. Setup the GPO at Computer Configuration > Administrative Templates > Classic Administrative Templates (ADM) > Microsoft Edge > Extensions > Control which extensions are installed silently (Change to "Enabled") together the following:


    For newer version, native Edge add-on is recommended:

    Reference:


  • Wei
    Wei W/ Alumni Posts: 2 Security Scout
    Answer ✓

    We indeed followed the tutorial for deploying the extension using GPO.

    We applied the same GPO on 2 computers, a W11 fully updated and a W10 1909.

    Everything is working fine on W10, the extension is installed and enabled.

    On W11, the extension is installed but disabled, with the option greyed out.

    We tried other extensions in the GPO, and they worked fine, only the f-secure extension was stuck disabled.

    We managed to enable the extension by going to the Microsoft extension store page.

    On this page, the enabled option wasn't greyed out.

    We tried a second computer on W11 and got the same result and we still don't understand this behavior.

    As such, we found a way resolve the problem, but we won't be able to deploy it globally if our IT team need to go on every W11 computers to manually enable it.

This discussion has been closed.