Unable to connect to the Policy Manager Server after upgrading Policy Manager Symptoms
Policy Manager Console prompts an error message: "Cannot connect to the server: localhost:8080. Check that the host name and port number are correct. Port number 8080 is used by default."
Diagnosis
This may be a TCP port conflict. Policy Manager has a port for client and Policy Manager communication which is supported by the clients. The default listening port is 443.
If you already have a service running on this port, this prevents Policy Manager Server from starting, thus not allowing you to login using Policy Manager.
Solution
If you suspect that you have a service running on port 443, run the following command in command prompt (run as administrator) to check:
netstat -anb > ports.txt
. This redirects the output to a file called ports.txt. Open the file to view the information. Below is a partial sample of the output. Proto Local Address Foreign Address State TCP 0.0.0.0:135 0.0.0.0:0 LISTENING RpcSs System] TCP 0.0.0.0:443 0.0.0.0:0 LISTENING someapplication.exe]
In this case, we already have an application listening on port 443 (someapplication.exe). Note that the default listening process in Policy Manager is java.exe. As both applications are configured to use the same port, there is a conflict. To fix the issue, two options are available.
- Change the conflicting port used by someapplication.exe
- Consult the documentation for someapplication.exe to find out how to change the port.
- Once the port is changed, restart Policy Manager server using an elevated command prompt;
net stop fsms
net start fsms
- Change the conflicting port in Policy Manager Server
In this example, we are changing the port from TCP 443 to TCP 444.
- Open Registry Editor.
- Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Data Fellows\F-Secure\Management Server 5.
- On the right pane, locate HttpsPortNum. Change the value from decimal 443 to 444.
- Restart Policy Manager Server using an elevated command prompt:
net stop fsms
net start fsms
- Start Status monitor in the Policy Manager program group, and change the default HTTPS port from 443 to 444.
- Go to the Advanced mode in Policy Manager Console, and navigate to F-Secure Managerment Agent > Settings > Communications > Protocols > HTTP > HTTPS Port.
- Change the default value from 443 to 444, and click the Force value to lock the settings.