Resetting a passcode from the F-Secure Elements Endpoint Protection portal fails on devices running on Android 7 and newer Symptoms
Resetting a passcode from the F-Secure Elements Endpoint Protection portal fails on devices running on Android 7 and newer, except for Samsung devices.
Diagnosis
Google has removed support for resetting Android devices' passcode or password from within a Device Administrator granted app since Android 7 (Nougat).
Samsung has its own API implementation and is not affected. Resetting still works on Samsung devices.
Solution
A passcode reset is not possible. If a code is not known, the only option is a factory reset.
If a passcode was set by the policy, it may be found from the Device details view in the F-Secure Elements EPP portal (applies to Freedome for Business only).